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What’s new in Modes Complete version 1.5  

1 Upgrading from version 1.4 

Word search  
Modes Complete 1.5 includes a new Word search feature on the 
toolbar.  This is now the fastest way to search a Modes data file.  

When you type into this search box, any matching terms in the 
database immediately appear as a list.  You can select a term from 
the list to mark or subset the corresponding records.  

Indexed search  
Indexed search is very much faster in this version.  We estimate that searches are up to 20 
times faster than previously.  The list of keys is generated almost instantly when the default 
Begins option is selected.   

 

Text search  
Text search has also got a lot faster in 
our latest version.   

You can search at lightning speeds 
when the default Whole word option 
is selected. 

 

Warning before opening same file twice 
Users sometime get into difficulties 
when they unintentionally open the 
same file twice.   

The new version will warn you before 
opening a file, if that file is open 
already. 

 

Text nodes in Editor 
Users sometimes get into difficulties when they unintentionally create a TEXT_NODE 
element in the Editor screen.  We have removed the options which allowed this to happen. 
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Grids, Indexes and Templates 
The upgrade package includes options to import new grids, indexes and templates. See 
our Upgrade overview document for a full list of these. 

Automatic insertion of current date, time and username 
Templates and stored element groups can now include tags which represent the current 
date, time and username.  When a record is created from template, or when an element 
group is inserted, the date, time or username will be added to the record automatically.   

Barcodes  
Barcode labels can now be generated to represent storage locations, and there is an option 
to include barcodes in the PDF full record outputs. 

Hazard icons  
Records can be flagged with hazard 
icons, which will appear in the 
Browser, PDF and Grid views.  

Multimedia icons  
We’ve added an option to use larger icons for linked multimedia files on the Multimedia 
tab.  

Easy set up for local termlists 
We’ve provided pre-defined termlists for object names, classifications, and object locations, 
ready for you to populate with your own list of terms. 

Calendar reminders 
You can create and save calendar reminders for return dates for loans, object entry and 
object exit records in the Procedures application. 

New standalone database component (NexusDB 4.50) 
The standalone client is now written in NexusDB 4.50.  This means that standalone data 
files are now fully interchangeable with networked data files.  This will allow version 1.4 
users to set up standalone copies of their networked data files more easily. 

Derive XPath 
The Derive XPath and drag-and-drop methods for setting up new grid columns now always 
create a specific path with an occurrence number for each element.  New columns will no 
longer display scrolling cells by default. 

Excel imports 
Modes Complete 1.5 supports direct import from Excel.  Spreadsheets must be prepared 
to a standard format and saved as XML. 

Windows 10 compatibility 
Modes Complete version 1.5.1.7 fixes a problem with running Modes Complete in 
Windows 10 version 2004 (and later). 



 
 

3 

2 Upgrading from version 1.3 

Users upgrading from version 1.3 will add features which were previously included in the 
version 1.4 upgrade: 

Spectrum 5.0 compliance 
Modes Complete 1.4 was the first UK collections management system to be compliant with 
Spectrum 5.0.  The Spectrum 5 help file supplied with the program now includes examples 
of how to record each Spectrum Unit of Information in Modes.   

We have added two new Procedures files – Collections review information and 
Reproduction information.  We have added new elements to improve alignment with 
Spectrum 5.0.  A list of these revisions can be found at the beginning of the Object 
elements help file. 

Font selection for views and outputs 
We have made it easier to select 
the font you want to use for any of 
the views and outputs.  

Select Options > Font to set your 
preference. The font you select 
will be used for all views and 
outputs, as well as for editing.  

Because font selections are a user 
option, different users can choose 
different fonts. 

 

New PDF views 
The familiar Full record display on the Browser tab now has its counterpart on the PDF tab. 

Select the PDF tab, then select Full record from the toolbar. This replicates the layout of 
the Browser view, but in a paginated print-ready format which is easy to email or save as a 
PDF file.  

Also included as PDF outputs are Full record (omitting confidential elements) and Full 
record (omitting empty elements).   

New ‘readers’ group 
Read-only users in the ‘public’ group have limited access to grids, indexes, views and 
reports.  This is to protect reseachers from accessing sensitive data. 

As this may be too restrictive for some read-only users, we have added a user group called 
‘readers’ who have full access to grids, indexes, views and reports in read-only mode. 
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Support for GDPR 
New access controls for grids and indexes, and new password options, give better 
protection to your personal data.  We have added a new Consent element within the 
Person group to allow to you record the consent given for the collection and use of an 
individual’s personal data.  

Access rights for Grids 
We have restricted access to grids by ‘public’ or ‘read-only’ users, to protect sensitive data.  
Read-only users cannot create new grids, and can select only grids which have been 
assigned to them by the administrator1.  

Grids can be restricted for other user groups too.  This also allows you to reduce the 
‘clutter’ of unused grids.  

Access rights for Indexes 
Indexes can be restricted to particular user groups, to protect sensitive data.  This also 
allows you to reduce the ‘clutter’ of unused indexes. 

Advanced password options 
We have added new options for enforcing password security.  In Modes Admin you can set 
the maximum and minimum length of a password; whether it should contain uppercase, 
lowercase, digits, or other characters; how frequently passwords should expire, and whether 
they can be re-used.   

You can continue to use Modes without these restrictions. 

Fix for problem with printing from Grid and creating PDFs 
We have fixed a problem with generating PDF outputs, which many users experienced 
when trying to print data from the Grid. 

Export larger files from the grid 
Users often found it difficult to save 
more than a few hundred records 
from the grid.   

Version 1.4 can process large exports 
from the grid very quickly.  

Save the whole grid as a CSV file 
which you can open in Excel. 

 

 
1 First included in August 2016 revision of version 1.3 
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Confidential element selection 
Some views and outputs are designed to suppress ‘confidential’ elements (such as 
Valuation).  We’ve made it easy to select which elements are treated as ‘confidential’ using 
options in the Modes Admin program. 

 

Validation settings for global updates 
When running global 
updates (Edit > Update and 
Edit > Global grid edits) 
records will be validated by 
default. 

 

Import files from Modes Compact 
Modes Complete users can now import records directly from a Modes Compact backup, 
without any preparation or conversion.  Modes Compact users cannot import records from 
Modes Complete. 
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Fit to width setting for grids  
The Fit to width option on the Grid toolbar now works 
consistently for screen display, printing and PDF outputs2.  When 
Fit to width is selected, the grid will expand the full width of the 
page or screen.  

 

Descriptive names for Indexes 
A descriptive name or alias can be assigned to an index in the Modes Admin program.  For 
example, an index called ‘People and organisations – acquired from’ could be labelled with 
the alias ‘Donors’ names’. This helps you to customise the program with your own 
preferences.  The descriptive name can be changed without the need to re-index the file.   

 

 

Restrictions on image folders 
We’ve added an option in Modes Admin to prevent users from dragging-and-dropping 
images from any folder which is not listed in a media control.  This gives administrators 
control over where images are stored. 

System data for indexes 
You can quickly check which field or fields an index is reading from. Select System data > 
Indexes from the View menu. This displays the name and description of each index along 
with the xpath for the field the index is compiled from. 

 
2 First included in the November 2016 revision of version 1.3 
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Default for Save subset bookmark  
We have changed the default for 
Save subset bookmark from ID to 
Primary key.  This removes a difficulty 
which many users experienced with 
restoring subsets in files where ID 
numbers had changed.   

The Primary key option is always 
reliable, although it is considerably 
slower to save the bookmark file.   

New server component (NexusDB 4.50) 
The most significant part of the upgrade is ‘behind the scenes’ and will not affect most 
users’ experience of Modes Complete.  We have updated the core database from NexusDB 
version 2.08 to version 4.50.  This will fix problems which some users experienced in 
running Modes on Windows Server 2012.   

This brings the ModesServer component fully up to date, and will provide the foundation 
for the future development of Modes. It includes a browser-based console for managing 
the ModesServer settings, and will allow us to develop Modes Complete in a browser-
based interface.  A prototype is available for demonstration. 

Windows 10 compatibility 
Modes Complete version 1.4.2.47 fixed a problem with running Modes Complete in 
Windows 10 version 1809 (and later). 
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3 Upgrading from version 1.2 

In addition to the above, users upgrading from version 1.2 will add features which were 
previously included in the version 1.3 upgrade: 

Indexed search  
Select all, Deselect all and Reverse selection buttons allow you quickly to select all of the 
items in the list, undo, or reverse your selections.  

 

Spell checking  
Right-click on any element to check the spelling. But 
we’ve removed the pop-up which checked all the 
spellings whether you wanted it to or not!  

 

Image drag and drop  
Options for EXIF data and IPTC data are now deselected by default.  This makes it easier to 
keep your records clear of unwanted detail. 
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Elements help  
Ever wondered how to use a particular element?  

By right-clicking on an element in the Editor tab, you 
can now choose Elements help to display a definition 
and examples of how to use the element.  

 

Also, we fixed a problem where Help pages were sometimes too wide to print.  

Validation check  
Hover the mouse over the red cross to check on the the type of validation error.  

  
 

Sort grid  
A new toolbar button gives easy access to the Sort data grid feature, and this 
feature has been redesigned to give easier setup of Grid sorting.   

  

Linking to other records  
We’ve made it easier to hyperlink to other records about related objects, people, places 
and events.  

Recording Archives  
We’ve added support for recording archives, including new templates mapped to the 
ISAD(G) standard.  
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Outputs, views and reports  
We’ve de-cluttered the views and reports so that it is 
easier to find what you need.  

We’ve added new reports, including:  

• Update locations 

This allows you quickly to update batches of 
records with new ObjectLocations. 

• Re-order elements  

This allows you to re-arrange the structure of your 
existing records to match a sample record or 
template.  

• Clone current record  

Create multiple copies of a record.    

Modes Admin: Report options tab  
The Report options tab allows you to customise settings used in reports and other outputs. 
These include the museum name, address and contact details, the logo to be included at 
the bottom of each page; margins, fonts and other layout settings; default rights and 
licensing for publication; options for map outputs.   

Modes Admin: Index strategies 
To overcome a problem in indexing accented or non-Latin characters, we have introduced 
two new indexing strategies. eachwordunicode and wordincontextunicode will support 
indexing of a wide range of accented Latin alphabet characters, plus Greek and Cyrillic.  

Modes Admin: Publication tab 
The Publication tab allows you to set up control records which can be used to enable 
publication of your data using the Modes Linked Data Framework.   

  

 

 


