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What’s new in Modes Complete version 1.4  

Spectrum 5.0 compliance 
Modes Complete 1.4 is the first UK collections management system to be compliant with 
Spectrum 5.0.  The Spectrum 5 help file supplied with the program now includes examples 
of how to record each Spectrum Unit of Information in Modes.   

We have added two new Procedures files – Collections review information and 
Reproduction information.  We have added new elements to improve alignment with 
Spectrum 5.0.  A list of these revisions can be found at the beginning of the Object 
elements help file. 

Text search  
Text search has got a lot faster in our 
latest version (1.4.2.56 onwards).  
You can now search larger files at 
lightning speeds when the ‘Whole 
word’ option is selected.   

 

Export larger files from the grid 
Modes used to stall when you tried to 
save more than a few hundred 
records from the grid.   

Version 1.4 can now process large 
exports from the grid very quickly.  

Save the whole grid as a CSV file 
which you can open in Excel. 
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Font selection for views and outputs 
We have made it easier to 
select the font you want to use 
for any of the views and 
outputs.  

Select Options > Font to set 
your preference. The font you 
select will be used for all views 
and outputs, as well as for 
editing.  

Because font selections are a 
user option, different users can 
choose different fonts. 

 

New PDF views 
The familiar Full record display on the Browser tab now has its counterpart on the PDF tab. 

Select the PDF tab, then select Full record from the toolbar. This replicates the layout of 
the Browser view, but in a paginated print-ready format which is easy to email or save as a 
PDF file.  

Also included as PDF outputs are Full record (omitting confidential elements) and Full 
record (omitting empty elements).   

Support for GDPR 
New access controls for grids and indexes, and new password options, give better 
protection to your personal data.  We have added a new Consent element within the 
Person group to allow to you record the consent given for the collection and use of an 
individual’s personal data.  

Access rights for Grids 
We have restricted access to grids by ‘public’ or ‘read-only’ users, to protect sensitive data.  
Read-only users cannot create new grids, and can select only grids which have been 
assigned to them by the administrator1.  

Grids can be restricted for other user groups too.  This also allows you to reduce the 
‘clutter’ of unused grids.  

Access rights for Indexes 
Indexes can be restricted to particular user groups, to protect sensitive data.  This also 
allows you to reduce the ‘clutter’ of unused indexes. 

 
1 First included in August 2016 revision of version 1.3 
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Advanced password options 
We have added new options for enforcing password security.  In Modes Admin you can set 
the maximum and minimum length of a password; whether it should contain uppercase, 
lowercase, digits, or other characters; how frequently passwords should expire, and whether 
they can be re-used.   

You can continue to use Modes without these restrictions. 

New ‘readers’ group 
Read-only users in the ‘public’ group have limited access to grids, indexes, views and 
reports.  This is to protect reseachers from accessing sensitive data. 

As this may be too restrictive for some read-only users, we have added a user group called 
‘readers’ who have full access to grids, indexes, views and reports in read-only mode. 

New server component (NexusDB 4.50) 
The most significant part of the upgrade is ‘behind the scenes’ and will not affect most 
users’ experience of Modes Complete.  We have updated the core database from NexusDB 
version 2.08 to version 4.50.  This will fix problems which some users experienced in 
running Modes on Windows Server 2012.   

This brings the ModesServer component fully up to date, and will provide the foundation 
for the future development of Modes. It includes a browser-based console for managing 
the ModesServer settings, and will allow us to develop Modes Complete in a browser-
based interface.  A prototype is available for demonstration. 

Confidential element selection 
Some views and outputs are designed to suppress ‘confidential’ elements (such as 
Valuation).  We’ve made it easy to select which elements are treated as ‘confidential’ using 
options in the Modes Admin program. 
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Validation settings for global updates 
When running global 
updates (Edit > Update 
and Edit > Global grid 
edits) records will be 
validated by default. 

 

Descriptive names for Indexes 
A descriptive name or alias can be assigned to an index in the Modes Admin program.  For 
example, an index called ‘People and organisations – acquired from’ could be labelled with 
the alias ‘Donors’ names’. This helps you to customise the program with your own 
preferences.  The descriptive name can be changed without the need to re-index the file.   
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System data for indexes 
You can quickly check which field or fields an index is reading from. Select System data > 
Indexes from the View menu. This displays the name and description of each index along 
with the xpath for the field the index is compiled from. 

 

Import files from Modes Compact 
Modes Complete users can now import records directly from a Modes Compact backup, 
without any preparation or conversion.  Modes Compact users cannot import records from 
Modes Complete. 

Fit to width setting for grids  
The Fit to width option on the Grid toolbar now works 
consistently for screen display, printing and PDF outputs2.  When 
Fit to width is selected, the grid will expand the full width of the 
page or screen.  

 

Default for Save subset bookmark  
We have changed the default for 
Save subset bookmark from ID to 
Primary key.  This removes a 
difficulty which many users 
experienced with restoring subsets 
in files where ID numbers had 
changed.   

The Primary key option is always 
reliable, although it is considerably 
slower to save the bookmark file.  

 

Restrictions on image folders 
We’ve added an option in Modes Admin to prevent users from dragging-and-dropping 
images from any folder which is not listed in a media control.  This gives administrators 
control over where images are stored. 

 
2 First included in the November 2016 revision of version 1.3 
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Upgrading from version 1.2 

Users upgrading from version 1.2 will add features which were previously included in the 
version 1.3 upgrade: 

Indexed search  
Select all, Deselect all and Reverse selection buttons allow you quickly to select all of the 
items in the list, undo, or reverse your selections.  

 

Spell checking  
Right-click on any element to check the spelling. But 
we’ve removed the pop-up which checked all the 
spellings whether you wanted it to or not!  

 

Image drag and drop  
Options for EXIF data and IPTC data are now deselected by default.  This makes it easier to 
keep your records clear of unwanted detail. 
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Elements help  
Ever wondered how to use a particular element?  

By right-clicking on an element in the Editor tab, you 
can now choose Elements help to display a definition 
and examples of how to use the element.  

 

Also, we fixed a problem where Help pages were sometimes too wide to print.  

Validation check  
Hover the mouse over the red cross to check on the the type of validation error.  

  
 

Sort grid  
A new toolbar button gives easy access to the Sort data grid feature, and this 
feature has been redesigned to give easier setup of Grid sorting.   

  

Linking to other records  
We’ve made it easier to hyperlink to other records about related objects, people, places 
and events.  

Recording Archives  
We’ve added support for recording archives, including new templates mapped to the 
ISAD(G) standard.  
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Outputs, views and reports  
We’ve de-cluttered the views and reports so that it is 
easier to find what you need.  

We’ve added new reports, including:  

• Update locations 

This allows you quickly to update batches of 
records with new ObjectLocations. 

• Re-order elements  

This allows you to re-arrange the structure of your 
existing records to match a sample record or 
template.  

• Clone current record  

Create multiple copies of a record.   
 

Modes Admin: Report options tab  
The Report options tab allows you to customise settings used in reports and other outputs. 
These include the museum name, address and contact details, the logo to be included at 
the bottom of each page; margins, fonts and other layout settings; default rights and 
licensing for publication; options for map outputs.   

Modes Admin: Index strategies 
To overcome a problem in indexing accented or non-Latin characters, we have introduced 
two new indexing strategies. eachwordunicode and wordincontextunicode will support 
indexing of a wide range of accented Latin alphabet characters, plus Greek and Cyrillic.  

Modes Admin: Publication tab 
The Publication tab allows you to set up control records which can be used to enable 
publication of your data using the Modes Linked Data Framework.  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Reference: Grids, Indexes and Templates 
The following templates, grids and indexes are included with the version 1.4 upgrade 
package. 

Object application 

Grids: 

_Inventory 

Accessions register 

Classifications 

Collections care 

Image lightbox 

Multimedia 

Object locations 

Record editing history 

Summary - association 

Summary - association 

Summary - content 

Summary - content 

Summary - description 

Summary - field collection 

Summary - field collection 

Summary - production 

Indexes: 

_source templates 

Classifications 

Dates 

Entry number 

Events 

How acquired 

Identity number 

Image filenames 

Item marked 

Locations – current location 

Locations – normal location 

Materials 

Multimedia filenams 

Object names 

Object simple names 

Other identity numbers 

People and organisations – acquired from 

People and organisations – associated 

Periods 

Places 

Recording progress 

Titles 

Word search 

Templates: 

_inventory template 

archaeology template 

books template 

coins template 

costume template 

decorative art template 

digital image template 

document template 
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ethnography/folk life template event template 

Templates (continued): 

fine art template 

geology template 

loan in template 

medals template 

mineral specimen template 

natural history template 

oral history template 

organisation template 

person template 

photograph template 

place template 

social history template 

technology/transport template 

 

Procedures application 

Grids: 

Acquisition 

Loans in 

Loans out 

Movements 

Object entry 

Object exit 

Record editing history 

Indexes: 

_source templates 

Acquisition reference number 

Audit reference number 

Collections review number 

Condition check reference number 

Conservation number 

Dates - date of entry 

Dates - date of exit 

Dates - date returned 

Dates - date returned 

Dates - delivery date 

Dates - planned removal dates 

Dates - removal dates 

Dates - return due 

Dates - return due 

Disposal reference number 

Entry number 

Entry number 

Exit number 

Exit number 

Incident number 

Insurance or indemnity reference number 

Loan in number 

Loan out number 

Locations - new location 

Locations - previous location 

Movement number 

Object names 

Peoples names 

Process reference number 
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Indexes (continued): 

Reasons for entry 

Reasons for exit 

Reproduction number 

Use of collections reference number 

Valuation reference number 

Word search 

Templates: 

acquisition template 

audit template 

collections review 
template 

condition check/technical 
assessment template 

conservation and 
treatment template 

disposal template 

exhibition template 

indemnity template 

insurance template 

loan in template 

loan out template 

loss/damage template 

movement template 

object entry template 

object exit template 

process template 

reproduction template 

use of collections 
template 

valuation template 

 


